arp-sk-0.0.16-r2.ebuild 761 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils multilib
  5. DESCRIPTION="A swiss knife tool for ARP"
  6. HOMEPAGE="http://sid.rstack.org/arp-sk/"
  7. SRC_URI="http://sid.rstack.org/arp-sk/files/${P}.tgz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86"
  11. DEPEND=">=net-libs/libnet-1.1"
  12. RDEPEND="${DEPEND}"
  13. DOCS=( ARP AUTHORS CONTRIB ChangeLog README TODO )
  14. src_prepare() {
  15. epatch "${FILESDIR}"/${P}-libnet1_2.patch
  16. sed -i configure.in -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' || die
  17. rm missing || die
  18. epatch_user
  19. eautoreconf
  20. }
  21. src_install() {
  22. default
  23. # We don't need libcompat as it has a potential to clash with other packages.
  24. rm -fr "${D}"/usr/$(get_libdir)
  25. }