cutter-1.04.ebuild 648 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="TCP/IP Connection cutting on Linux Firewalls and Routers"
  6. HOMEPAGE="http://www.digitage.co.uk/digitage/software/linux-security/cutter"
  7. SRC_URI="http://www.digitage.co.uk/digitage/files/${PN}/${P}.tgz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc ~x86"
  11. src_prepare() {
  12. epatch "${FILESDIR}"/${PN}-1.03-debian.patch
  13. rm -f Makefile # implicit rules are better ;x
  14. }
  15. src_compile() {
  16. emake cutter CC="$(tc-getCC)"
  17. }
  18. src_install() {
  19. dosbin cutter
  20. dodoc README
  21. doman debian/cutter.8
  22. }