scli-0.4.0-r1.ebuild 701 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils
  5. DESCRIPTION="SNMP Command Line Interface"
  6. HOMEPAGE="http://cnds.eecs.jacobs-university.de/users/schoenw/articles/software/index.html"
  7. SRC_URI="ftp://ftp.ibr.cs.tu-bs.de/pub/local/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86 ~amd64-linux"
  11. RDEPEND="
  12. dev-libs/glib:2
  13. dev-libs/libxml2
  14. net-libs/gnet
  15. net-libs/gsnmp
  16. sys-libs/ncurses
  17. sys-libs/readline
  18. sys-libs/zlib
  19. "
  20. DEPEND="
  21. ${RDEPEND}
  22. virtual/pkgconfig
  23. "
  24. DOCS=( AUTHORS ChangeLog NEWS PORTING README TODO )
  25. src_prepare() {
  26. epatch "${FILESDIR}"/${P}-configure.patch
  27. eautoreconf
  28. }