arm-1.4.5.0-r2.ebuild 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. PYTHON_REQ_USE='ncurses'
  6. DISTUTILS_SINGLE_IMPL=1
  7. inherit distutils-r1
  8. DESCRIPTION="A ncurses-based status monitor for Tor relays"
  9. HOMEPAGE="http://www.atagar.com/arm/"
  10. SRC_URI="http://www.atagar.com/arm/resources/static/${P}.tar.bz2"
  11. LICENSE="GPL-3"
  12. SLOT="0"
  13. KEYWORDS="amd64 x86 ~x86-fbsd"
  14. IUSE=""
  15. # Note: While we depend on net-vpn/tor, we strictly speaking
  16. # don't have to because it could run on a different machine.
  17. RDEPEND="
  18. >=net-vpn/tor-0.2.1.27
  19. app-admin/sudo
  20. sys-process/lsof
  21. net-dns/bind-tools
  22. virtual/man"
  23. DEPEND="${RDEPEND}"
  24. S="${WORKDIR}/${PN}"
  25. python_prepare_all() {
  26. python_fix_shebang .
  27. distutils-r1_python_prepare_all
  28. }
  29. python_install() {
  30. distutils-r1_python_install \
  31. --docPath "${EPREFIX}/usr/share/doc/${PF}"
  32. sed -i -e "s:python:${EPYTHON}:" "${ED}"usr/bin/arm || die
  33. }
  34. pkg_postinst() {
  35. elog "Some graphing data issues have been noted in testing"
  36. elog "when run as root. It is not recommended to run arm as"
  37. elog "root until those issues have been isolated and fixed."
  38. elog
  39. elog "Trouble with graphs under app-misc/screen? Try:"
  40. elog 'TERM="rxvt-unicode" arm'
  41. }