connman-gtk-1.0-r1.ebuild 696 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools
  5. DESCRIPTION="GTK GUI for Connman"
  6. HOMEPAGE="https://github.com/jgke/connman-gtk"
  7. SRC_URI="https://github.com/jgke/connman-gtk/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="openconnect"
  12. CDEPEND="
  13. >=dev-libs/glib-2.0:2
  14. >=x11-libs/gtk+-3.10:3
  15. openconnect? ( >=net-vpn/openconnect-5.99 )
  16. "
  17. RDEPEND="${CDEPEND}
  18. net-misc/connman
  19. "
  20. DEPEND="${CDEOEND}
  21. >=dev-util/intltool-0.35.0
  22. sys-devel/gettext
  23. virtual/pkgconfig
  24. "
  25. src_prepare() {
  26. default
  27. eautoreconf
  28. }
  29. src_configure() {
  30. econf \
  31. $(use_with openconnect)
  32. }