grdesktop-0.23-r1.ebuild 960 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit gnome2
  5. DESCRIPTION="Gtk2 frontend for rdesktop"
  6. HOMEPAGE="http://www.nongnu.org/grdesktop/"
  7. SRC_URI="https://savannah.nongnu.org/download/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc sparc x86 ~x86-fbsd"
  11. IUSE=""
  12. RDEPEND="
  13. x11-libs/gtk+:2
  14. >=gnome-base/libgnomeui-2
  15. net-misc/rdesktop
  16. gnome-base/gconf:2
  17. "
  18. DEPEND="${RDEPEND}
  19. app-text/rarian
  20. virtual/pkgconfig
  21. "
  22. src_prepare() {
  23. # Correct icon path. See bug #50295.
  24. eapply "${FILESDIR}/${P}-desktop.patch"
  25. # Fix compilation with format-security, bug #517662
  26. eapply "${FILESDIR}/${P}-format-security.patch"
  27. sed -e 's/\(GETTEXT_PACKAGE = \)@GETTEXT_PACKAGE@/\1grdesktop/g' \
  28. -i po/Makefile.in.in || die "sed 2 failed"
  29. gnome2_src_prepare
  30. }
  31. src_configure() {
  32. gnome2_src_configure \
  33. --disable-debug \
  34. --with-keymap-path=/usr/share/rdesktop/keymaps/
  35. }