polly-0.93.11.ebuild 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. PYTHON_REQ_USE=( gdbm )
  6. inherit distutils-r1 gnome2-utils vcs-snapshot
  7. DESCRIPTION="twitter client designed for multiple columns of multiple accounts"
  8. HOMEPAGE="https://launchpad.net/polly"
  9. SRC_URI="https://launchpad.net/${PN}/1.0/pre-alpha-2/+download/Polly-${PV}%20%28pre-alpha%203.11%29.tar.gz -> ${P}.tar.gz"
  10. LICENSE="CC-BY-NC-SA-3.0 GPL-2 GPL-3+ MIT"
  11. SLOT="0"
  12. KEYWORDS="~amd64"
  13. IUSE=""
  14. RDEPEND="${PYTHON_DEPS}
  15. dev-python/dbus-python[${PYTHON_USEDEP}]
  16. dev-python/gconf-python[${PYTHON_USEDEP}]
  17. dev-python/gtkspell-python[${PYTHON_USEDEP}]
  18. dev-python/httplib2[${PYTHON_USEDEP}]
  19. dev-python/keyring[${PYTHON_USEDEP}]
  20. dev-python/notify-python[${PYTHON_USEDEP}]
  21. dev-python/numpy[${PYTHON_USEDEP}]
  22. dev-python/oauth2[${PYTHON_USEDEP}]
  23. dev-python/pycurl[${PYTHON_USEDEP}]
  24. dev-python/pyxdg[${PYTHON_USEDEP}]
  25. dev-python/PySocks[${PYTHON_USEDEP}]"
  26. DEPEND="${RDEPEND}"
  27. python_prepare_all() {
  28. rm -rf external/keyring || die
  29. distutils-r1_python_prepare_all
  30. }
  31. pkg_preinst() {
  32. gnome2_gconf_savelist
  33. }
  34. pkg_postinst() {
  35. gnome2_gconf_install
  36. }
  37. pkg_postrm() {
  38. gnome2_gconf_uninstall
  39. }