pump-0.8.24-r4.ebuild 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils toolchain-funcs
  5. PATCHLEVEL="7"
  6. DESCRIPTION="This is the DHCP/BOOTP client written by RedHat"
  7. HOMEPAGE="http://ftp.debian.org/debian/pool/main/p/pump/"
  8. SRC_URI="mirror://debian/pool/main/p/${PN}/${PN}_${PV}.orig.tar.gz
  9. mirror://debian/pool/main/p/${PN}/${PN}_${PV}-${PATCHLEVEL}.diff.gz"
  10. LICENSE="GPL-2"
  11. SLOT="0"
  12. KEYWORDS="amd64 arm hppa ia64 ppc sparc x86"
  13. IUSE=""
  14. DEPEND=">=dev-libs/popt-1.5"
  15. RDEPEND="${DEPEND}"
  16. src_prepare() {
  17. # Fix Debian patch to fit epatch logic
  18. sed -i \
  19. -e 's:/debian::g' \
  20. -e '/^---/s:pump-0.8.24.orig/::' \
  21. -e '/^+++/s:pump-0.8.24/::' \
  22. "${WORKDIR}/${PN}_${PV}-${PATCHLEVEL}.diff" || die "sed on ${PN}_${PV}-${PATCHLEVEL}.diff failed"
  23. # Apply Debians pump patchset - they fix things good :)
  24. # Debian patchset 7 include gentoo patchset too
  25. epatch "${WORKDIR}/${PN}_${PV}-${PATCHLEVEL}.diff"
  26. # Add LC_ALL workaround to make sure that patches are applied in right order(bug 471666)
  27. LC_ALL=C EPATCH_FORCE="yes" EPATCH_SOURCE="patches" EPATCH_SUFFIX="patch" epatch
  28. # respect AR, wrt bug #458482
  29. tc-export AR
  30. epatch_user
  31. }
  32. src_compile() {
  33. emake CC="$(tc-getCC)" DEB_CFLAGS="-fPIC ${CFLAGS}" pump
  34. }
  35. src_install() {
  36. exeinto /sbin
  37. doexe pump
  38. doman pump.8
  39. dodoc changelog CREDITS
  40. dolib.a libpump.a
  41. doheader pump.h
  42. }