redir-2.2.1.ebuild 731 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="2"
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="Redir is a port redirector"
  6. HOMEPAGE="http://sammy.net/~sammy/hacks/"
  7. SRC_URI="http://sammy.net/~sammy/hacks/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="alpha ~amd64 ~hppa ~mips sparc x86"
  11. IUSE=""
  12. DEPEND=""
  13. RDEPEND=""
  14. src_configure() {
  15. epatch "${FILESDIR}/${P}-include.patch"
  16. }
  17. src_compile() {
  18. emake \
  19. CC="$(tc-getCC)" \
  20. CFLAGS="${CFLAGS}" \
  21. LDFLAGS="${LDFLAGS}" || \
  22. die "emake failed"
  23. }
  24. src_install() {
  25. dobin redir || die "dobin failed"
  26. newman redir.man redir.1 || die "doman failed"
  27. dodoc CHANGES README transproxy.txt || die "dodoc failed"
  28. }