httptunnel-3.3-r2.ebuild 658 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils toolchain-funcs
  5. DESCRIPTION="httptunnel can create IP tunnels through firewalls/proxies using HTTP"
  6. HOMEPAGE="http://www.nocrew.org/software/httptunnel.html"
  7. SRC_URI="http://www.nocrew.org/software/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. KEYWORDS="amd64 ppc x86 ~x86-fbsd"
  10. IUSE=""
  11. SLOT="0"
  12. DEPEND=""
  13. RDEPEND=""
  14. src_prepare() {
  15. epatch "${FILESDIR}"/${P}-fix_write_stdin.patch
  16. tc-export CC
  17. }
  18. src_configure() {
  19. ./configure \
  20. --host=${CHOST} \
  21. --prefix=/usr \
  22. --infodir=/usr/share/info \
  23. --mandir=/usr/share/man || die
  24. }