openfortivpn-1.3.0.ebuild 767 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools linux-info
  5. DESCRIPTION="A Fortinet compatible VPN client"
  6. HOMEPAGE="https://github.com/adrienverge/openfortivpn"
  7. SRC_URI="https://github.com/adrienverge/openfortivpn/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="GPL-3-with-openssl-exception openssl"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. IUSE="libressl"
  12. DEPEND="
  13. !libressl? ( dev-libs/openssl:0= )
  14. libressl? ( dev-libs/libressl:0= )
  15. net-dialup/ppp
  16. "
  17. RDEPEND="${DEPEND}"
  18. CONFIG_CHECK="~PPP ~PPP_ASYNC"
  19. src_prepare() {
  20. default
  21. sed -i 's/-Werror//g' Makefile.am || die "Failed to remove -Werror from Makefile.am"
  22. eautoreconf
  23. }
  24. src_install() {
  25. default
  26. keepdir /etc/openfortivpn
  27. }