rfkill-0.5-r1.ebuild 652 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit toolchain-funcs
  5. DESCRIPTION="Tool to read and control rfkill status through /dev/rfkill"
  6. HOMEPAGE="https://wireless.kernel.org/en/users/Documentation/rfkill"
  7. SRC_URI="https://www.kernel.org/pub/software/network/${PN}/${P}.tar.xz"
  8. LICENSE="ISC"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
  11. IUSE=""
  12. RDEPEND=""
  13. DEPEND=""
  14. src_prepare() {
  15. default
  16. sed -i "s|^SUFFIX=$|SUFFIX=-${PR}|" version.sh || die
  17. }
  18. src_compile() {
  19. emake CC=$(tc-getCC) LD=$(tc-getLD) V=1
  20. }
  21. src_install() {
  22. emake install V=1 DESTDIR="${D}"
  23. }