gibbs-3.1.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. AUTOTOOLS_AUTORECONF=yes
  5. inherit autotools-utils multilib
  6. DESCRIPTION="Identify motifs, conserved regions, in DNA or protein sequences"
  7. HOMEPAGE="http://bayesweb.wadsworth.org/gibbs/gibbs.html"
  8. SRC_URI="mirror://gentoo/gibbs-${PV}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. IUSE="mpi"
  12. KEYWORDS="amd64 x86"
  13. DEPEND="
  14. mpi? (
  15. virtual/mpi
  16. sys-cluster/mpe2 )"
  17. RDEPEND="${DEPEND}"
  18. src_prepare() {
  19. sed \
  20. -e 's/CFLAGS="$OPTFLAGS/CFLAGS="$CFLAGS $OPTFLAGS/' \
  21. -e 's/-Werror//' \
  22. -i configure.in || die
  23. autotools-utils_src_prepare
  24. }
  25. src_configure() {
  26. if use mpi; then export CC=mpicc; fi
  27. local myeconfargs=( $(use_enable mpi) )
  28. autotools-utils_src_configure
  29. }
  30. src_install() {
  31. autotools-utils_src_install
  32. exeinto /usr/$(get_libdir)/${PN}
  33. doexe *.pl
  34. dodoc README ChangeLog
  35. }
  36. pkg_postinst() {
  37. einfo "Supplementary Perl scripts for Gibbs have been installed into /usr/$(get_libdir)/${PN}."
  38. einfo "These scripts require installation of sci-biology/bioperl."
  39. }