mcl-08.312.ebuild 678 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. AUTOTOOLS_AUTORECONF=true
  5. inherit autotools-utils
  6. MY_P="${PN}-${PV/./-}"
  7. DESCRIPTION="A Markov Cluster Algorithm implementation"
  8. HOMEPAGE="http://micans.org/mcl/"
  9. SRC_URI="http://micans.org/mcl/src/${MY_P}.tar.gz"
  10. LICENSE="GPL-2"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~x86"
  13. IUSE="+blast"
  14. S="${WORKDIR}/${MY_P}"
  15. src_prepare() {
  16. find \
  17. -name Makefile.am \
  18. -exec sed \
  19. -e '/docdir/d' \
  20. -e '/exampledir/s:doc::g' \
  21. -i '{}' + || die
  22. autotools-utils_src_prepare
  23. }
  24. src_configure() {
  25. local myeconfargs=( $(use_enable blast) )
  26. autotools-utils_src_configure
  27. }