mcl-14.137.ebuild 651 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools
  5. MY_P="${PN}-${PV/./-}"
  6. DESCRIPTION="A Markov Cluster Algorithm implementation"
  7. HOMEPAGE="http://micans.org/mcl/"
  8. SRC_URI="http://micans.org/mcl/src/${MY_P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE="+blast"
  13. PATCHES=("${FILESDIR}/${P}-qa-implicit-declarations.patch")
  14. S="${WORKDIR}/${MY_P}"
  15. src_prepare() {
  16. find \
  17. -name Makefile.am \
  18. -exec sed \
  19. -e '/docdir/d' \
  20. -e '/exampledir/s:doc::g' \
  21. -i '{}' + || die
  22. default
  23. eautoreconf
  24. }
  25. src_configure() {
  26. econf $(use_enable blast)
  27. }