xcircuit-3.8.83.ebuild 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. AUTOTOOLS_AUTORECONF=yes
  5. inherit autotools-utils multilib
  6. DESCRIPTION="Circuit drawing and schematic capture program"
  7. SRC_URI="http://opencircuitdesign.com/xcircuit/archive/${P}.tgz"
  8. HOMEPAGE="http://opencircuitdesign.com/xcircuit"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~ppc ~x86"
  12. IUSE=""
  13. DEPEND="
  14. app-text/ghostscript-gpl
  15. dev-lang/tk:0
  16. sys-libs/zlib
  17. x11-libs/libX11
  18. x11-libs/libXt
  19. x11-libs/libXpm
  20. x11-libs/libSM
  21. x11-libs/libICE"
  22. RDEPEND=${DEPEND}
  23. RESTRICT="test" #131024
  24. AUTOTOOLS_IN_SOURCE_BUILD=1
  25. src_prepare() {
  26. # automake-1.12
  27. sed \
  28. -e '/AM_C_PROTOTYPES/d' \
  29. -i configure.in || die
  30. # automake-1.13
  31. mv configure.{in,ac} || die
  32. autotools-utils_src_prepare
  33. }
  34. src_configure() {
  35. export loader_run_path="/usr/$(get_libdir)"
  36. local myeconfargs=(
  37. --disable-dependency-tracking
  38. --with-tcl
  39. --with-ngspice
  40. )
  41. autotools-utils_src_configure
  42. }
  43. src_compile() {
  44. autotools-utils_src_compile appdefaultsdir="/usr/share/X11/app-defaults"
  45. }
  46. src_install () {
  47. autotools-utils_src_install \
  48. appdefaultsdir="/usr/share/X11/app-defaults" \
  49. appmandir="/usr/share/man/man1"
  50. }