1234567891011121314151617181920212223242526272829 |
- # Copyright 1999-2015 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI="5"
- PYTHON_COMPAT=( python2_7 python3_4 )
- inherit distutils-r1
- DESCRIPTION="Geometric objects, predicates, and operations"
- HOMEPAGE="https://pypi.python.org/pypi/Shapely"
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- LICENSE="BSD"
- SLOT="0"
- KEYWORDS="~amd64 ~x86"
- IUSE="test"
- RDEPEND=">=sci-libs/geos-3.1"
- DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
- PATCHES=( "${FILESDIR}"/setup_unicode.patch )
- python_test() {
- esetup.py test
- }
|