Shapely-1.3.2.ebuild 619 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. PYTHON_COMPAT=( python2_7 python3_4 )
  5. inherit distutils-r1
  6. DESCRIPTION="Geometric objects, predicates, and operations"
  7. HOMEPAGE="https://pypi.python.org/pypi/Shapely"
  8. SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
  9. LICENSE="BSD"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE="test"
  13. RDEPEND=">=sci-libs/geos-3.1"
  14. DEPEND="${RDEPEND}
  15. dev-python/setuptools[${PYTHON_USEDEP}]
  16. test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
  17. PATCHES=( "${FILESDIR}"/setup_unicode.patch )
  18. python_test() {
  19. esetup.py test
  20. }