libqalculate-0.9.7-r1.ebuild 1.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. DESCRIPTION="A modern multi-purpose calculator library"
  6. HOMEPAGE="http://qalculate.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/${P/lib}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
  11. IUSE="gnuplot readline static-libs"
  12. COMMON_DEPEND="
  13. dev-libs/glib:2
  14. dev-libs/libxml2:2
  15. >=sci-libs/cln-1.2
  16. sys-libs/zlib
  17. readline? ( sys-libs/readline:0= )"
  18. DEPEND="${COMMON_DEPEND}
  19. dev-util/intltool
  20. sys-devel/gettext
  21. virtual/pkgconfig"
  22. RDEPEND="${COMMON_DEPEND}
  23. net-misc/wget
  24. gnuplot? ( >=sci-visualization/gnuplot-3.7 )"
  25. src_prepare() {
  26. cat >po/POTFILES.skip <<-EOF
  27. # Required by make check
  28. data/currencies.xml.in
  29. data/datasets.xml.in
  30. data/elements.xml.in
  31. data/functions.xml.in
  32. data/planets.xml.in
  33. data/units.xml.in
  34. data/variables.xml.in
  35. src/defs2doc.cc
  36. EOF
  37. }
  38. src_configure() {
  39. econf \
  40. $(use_enable static-libs static) \
  41. $(use_with readline)
  42. }
  43. src_install() {
  44. # docs/reference/Makefile.am -> referencedir=
  45. emake \
  46. DESTDIR="${D}" \
  47. referencedir="${EPREFIX}/usr/share/doc/${PF}/html/reference" \
  48. install
  49. dodoc AUTHORS ChangeLog NEWS README* TODO
  50. prune_libtool_files
  51. }