libtifiles2-1.1.6-r1.ebuild 968 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools-utils
  5. DESCRIPTION="Library for TI calculator files"
  6. HOMEPAGE="http://lpg.ticalc.org/prj_tilp/"
  7. SRC_URI="mirror://sourceforge/tilp/tilp2-linux/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
  11. IUSE="doc nls static-libs"
  12. RDEPEND="
  13. app-arch/libarchive
  14. dev-libs/glib:2
  15. >=sci-libs/libticables2-1.3.3
  16. >=sci-libs/libticonv-1.1.3
  17. nls? ( virtual/libintl )"
  18. DEPEND="${RDEPEND}
  19. virtual/pkgconfig
  20. nls? ( sys-devel/gettext )"
  21. DOCS=( AUTHORS LOGO NEWS README ChangeLog docs/api.txt )
  22. src_prepare() {
  23. cd src
  24. sed -i -e "s|types\*.h|$(echo types*.h)|" Makefile.in || die
  25. autotools-utils_src_prepare
  26. }
  27. src_configure() {
  28. local myeconfargs=(
  29. --disable-rpath
  30. $(use_enable nls)
  31. )
  32. autotools-utils_src_configure
  33. }
  34. src_install() {
  35. autotools-utils_src_install
  36. use doc && dohtml docs/html/*
  37. }