libtifiles2-1.1.7.ebuild 902 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools
  5. DESCRIPTION="Library for TI calculator files"
  6. HOMEPAGE="http://lpg.ticalc.org/prj_tilp/"
  7. SRC_URI="mirror://sourceforge/tilp/tilp2-linux/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
  11. IUSE="doc nls static-libs"
  12. RDEPEND="
  13. app-arch/libarchive
  14. dev-libs/glib:2
  15. >=sci-libs/libticables2-1.3.3
  16. >=sci-libs/libticonv-1.1.3
  17. nls? ( virtual/libintl )"
  18. DEPEND="${RDEPEND}
  19. virtual/pkgconfig
  20. nls? ( sys-devel/gettext )"
  21. DOCS=( AUTHORS LOGO NEWS README ChangeLog docs/api.txt )
  22. src_prepare() {
  23. default
  24. eautoreconf
  25. }
  26. src_configure() {
  27. econf --disable-rpath \
  28. $(use_enable static-libs static) \
  29. $(use_enable nls)
  30. }
  31. src_install() {
  32. use doc && HTML_DOCS=( docs/html/. )
  33. default
  34. find "${D}" -name '*.la' -delete || die
  35. }