arcconf-1.2.20618.ebuild 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DESCRIPTION="Adaptec RAID Controller Command Line Utility"
  5. HOMEPAGE="http://www.adaptec.com/en-us/downloads/"
  6. SRC_URI="http://download.adaptec.com/raid/storage_manager/${PN}_v${PV//./_}.zip"
  7. LICENSE="Adaptec-EULA"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~x86"
  10. IUSE=""
  11. DEPEND="app-arch/unzip"
  12. RDEPEND=""
  13. RESTRICT="mirror bindist"
  14. # RESTRICT="fetch"
  15. QA_PRESTRIPPED="/opt/bin/arcconf"
  16. S="${WORKDIR}"
  17. # Maintainer notes:
  18. # * When going via the $HOMEPAGE one has to agree to the Adaptec-EULA as
  19. # referenced above.
  20. # * Despite that EULA, one can download the package seemingly without
  21. # restrictions from $SRC_URI.
  22. # * It is therefore assumed that the binary is made available for public
  23. # download. Even more so since the archive does not contain a license
  24. # agreement stating otherwise.
  25. #pkg_nofetch() {
  26. # einfo "Upstream has implemented a mandatory clickthrough EULA for distfile download"
  27. # einfo "Please visit $HOMEPAGE, choose a controller (for example the Series 7, 7805)"
  28. # einfo "and then navigate to Storage Manager Downloads for the ARCCONF Command Line Utility."
  29. # einfo "And place $A in ${DISTDIR}"
  30. #}
  31. # Maintainer notes:
  32. # * FreeBSD binaries would be available for FreeBSD 7..9, which ones do we need?
  33. src_install() {
  34. exeinto /opt/bin
  35. if use amd64 ; then
  36. doexe linux_x64/arcconf
  37. else
  38. doexe linux_x86/arcconf
  39. fi
  40. }