123456789101112131415161718192021222324252627282930 |
- # Copyright 1999-2013 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=5
- inherit eutils
- DESCRIPTION="LD_PRELOAD hack to convert sync()/msync() and the like to NO-OP"
- HOMEPAGE="https://launchpad.net/libeatmydata/"
- SRC_URI="https://launchpad.net/${PN}/trunk/${P}/+download/${P}.tar.gz"
- LICENSE="GPL-3"
- SLOT="0"
- KEYWORDS="~x86 ~amd64"
- IUSE=""
- # sandbox fools LD_PRELOAD and libeatmydata does not get control
- # bug/feature in sandbox?
- #DEPEND="test? ( dev-util/strace )"
- RESTRICT=test
- DEPEND="sys-apps/sed"
- RDEPEND=""
- src_install() {
- default
- prune_libtool_files --all
- dodoc AUTHORS README
- }
|