libeatmydata-82.ebuild 638 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. DESCRIPTION="LD_PRELOAD hack to convert sync()/msync() and the like to NO-OP"
  6. HOMEPAGE="https://launchpad.net/libeatmydata/"
  7. SRC_URI="https://launchpad.net/${PN}/trunk/${P}/+download/${P}.tar.gz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="~x86 ~amd64"
  11. IUSE=""
  12. # sandbox fools LD_PRELOAD and libeatmydata does not get control
  13. # bug/feature in sandbox?
  14. #DEPEND="test? ( dev-util/strace )"
  15. RESTRICT=test
  16. DEPEND="sys-apps/sed"
  17. RDEPEND=""
  18. src_install() {
  19. default
  20. prune_libtool_files --all
  21. dodoc AUTHORS README
  22. }