libaal-1.0.6.ebuild 792 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. inherit toolchain-funcs
  5. DESCRIPTION="library required by reiser4progs"
  6. HOMEPAGE="https://sourceforge.net/projects/reiser4/"
  7. SRC_URI="mirror://sourceforge/reiser4/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 arm ppc ppc64 -sparc x86"
  11. IUSE="static-libs"
  12. DEPEND="virtual/os-headers"
  13. src_prepare() {
  14. # remove stupid CFLAG hardcodes
  15. sed -i \
  16. -e "/GENERIC_CFLAGS/s:-O3::" \
  17. -e "/^CFLAGS=/s:\"\":\"${CFLAGS}\":" \
  18. configure || die "sed"
  19. printf '#!/bin/sh\n:\n' > run-ldconfig
  20. }
  21. src_configure() {
  22. econf \
  23. --enable-libminimal \
  24. --enable-memory-manager \
  25. $(use_enable static-libs static)
  26. }
  27. src_install() {
  28. default
  29. gen_usr_ldscript -a aal{,-minimal}
  30. }