libfaketime-0.9.6-r1.ebuild 776 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit toolchain-funcs multilib
  5. DESCRIPTION="Report faked system time to programs"
  6. HOMEPAGE="http://www.code-wizards.com/projects/libfaketime/ https://github.com/wolfcw/libfaketime/"
  7. SRC_URI="http://www.code-wizards.com/projects/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 arm arm64 hppa x86"
  11. src_prepare() {
  12. tc-export CC
  13. }
  14. src_compile() {
  15. emake CC="$(tc-getCC)" LIBDIRNAME="/$(get_libdir)" PREFIX=/usr
  16. }
  17. src_install() {
  18. dobin src/faketime
  19. doman man/faketime.1
  20. exeinto /usr/$(get_libdir)
  21. doexe src/${PN}*.so.*
  22. dosym ${PN}.so.1 /usr/$(get_libdir)/${PN}.so
  23. dosym ${PN}MT.so.1 /usr/$(get_libdir)/${PN}MT.so
  24. dodoc NEWS README TODO
  25. }