libstatgrab-0.91.ebuild 1022 B

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. AUTOTOOLS_AUTORECONF=frob
  5. inherit autotools-utils
  6. DESCRIPTION="A tool to provide access to statistics about the system on which it's run"
  7. HOMEPAGE="http://www.i-scream.org/libstatgrab/"
  8. SRC_URI="http://www.mirrorservice.org/sites/ftp.i-scream.org/pub/i-scream/libstatgrab/${P}.tar.gz"
  9. LICENSE="|| ( GPL-2 LGPL-2.1 )"
  10. SLOT=0
  11. KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86"
  12. IUSE="doc examples static-libs"
  13. RDEPEND="sys-libs/ncurses"
  14. DEPEND="${RDEPEND}"
  15. DOCS=( ChangeLog PLATFORMS NEWS AUTHORS README )
  16. PATCHES=( "${FILESDIR}"/${P}-tinfo.patch )
  17. src_configure() {
  18. local myeconfargs=(
  19. --disable-setgid-binaries
  20. --disable-setuid-binaries
  21. --with-ncurses
  22. $(use_enable static-libs static)
  23. )
  24. autotools-utils_src_configure
  25. }
  26. src_install() {
  27. autotools-utils_src_install
  28. if use examples; then
  29. docompress -x /usr/share/doc/${PF}/examples
  30. insinto /usr/share/doc/${PF}/examples
  31. doins -r examples/*
  32. fi
  33. }