mod_dnssd-0.6-r1.ebuild 872 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit apache-module eutils
  5. DESCRIPTION="mod_dnssd is an Apache module which adds Zeroconf support via DNS-SD using Avahi"
  6. HOMEPAGE="http://0pointer.de/lennart/projects/mod_dnssd/"
  7. SRC_URI="http://0pointer.de/lennart/projects/${PN}/${P}.tar.gz"
  8. LICENSE="BSD"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~arm x86"
  11. IUSE=""
  12. DEPEND="net-dns/avahi[dbus]"
  13. RDEPEND="${DEPEND}"
  14. APACHE2_MOD_CONF="80_${PN}"
  15. APACHE2_MOD_DEFINE="DNSSD"
  16. need_apache2
  17. src_prepare() {
  18. # Respect LDFLAGS and use LIBS properly.
  19. epatch "${FILESDIR}/${P}-ldflags.patch"
  20. # Fedora patch for apache 2.4
  21. epatch "${FILESDIR}/${P}-httpd24.patch"
  22. }
  23. src_configure() {
  24. econf --with-apxs=${APXS} --disable-lynx
  25. }
  26. # Do not use inherited src_compile since it doesn't do what we want
  27. src_compile() {
  28. emake
  29. }