libyui-3.2.5.ebuild 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit cmake-utils
  5. DESCRIPTION="UI abstraction library"
  6. HOMEPAGE="https://github.com/libyui/libyui"
  7. SRC_URI="https://github.com/libyui/${PN}/archive/${PN}/master/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="GPL-3"
  9. SLOT="0/6"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="gtk ncurses qt4 static-libs"
  12. # Only Boost headers are needed
  13. DEPEND="dev-libs/boost"
  14. PDEPEND="
  15. qt4? ( x11-libs/libyui-qt:${SLOT} )
  16. ncurses? ( x11-libs/libyui-ncurses:${SLOT} )
  17. gtk? ( x11-libs/libyui-gtk:${SLOT} )
  18. "
  19. PATCHES=( "${FILESDIR}/${PN}-3.0.13-fix-qt-libs-check.patch" )
  20. REQUIRED_USE="|| ( gtk ncurses qt4 )"
  21. S="${WORKDIR}/${PN}-${PN}-master-${PV}"
  22. src_prepare() {
  23. cp buildtools/CMakeLists.common CMakeLists.txt || die
  24. # TODO: set proper docs deps and USE flag for building them
  25. sed -i -e '/SET_AUTODOCS/d' CMakeLists.txt || die 'sed on CMakeLists.txt failed'
  26. sed -i -e 's/src examples/src/' PROJECTINFO.cmake || die 'sed on PROJECTINFO.cmake failed'
  27. cmake-utils_src_prepare
  28. }
  29. src_configure() {
  30. local mycmakeargs=(
  31. -DENABLE_WERROR=OFF
  32. -DDOC_DIR="${EPREFIX}/usr/share/doc/${P}"
  33. -DRESPECT_FLAGS=ON
  34. $(cmake-utils_use_enable static-libs STATIC)
  35. )
  36. cmake-utils_src_configure
  37. }