xcb-util-cursor-0.1.1-r1.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. XORG_MODULE=/
  5. XORG_BASE_INDIVIDUAL_URI=https://xcb.freedesktop.org/dist
  6. XORG_DOC=doc
  7. XORG_MULTILIB=yes
  8. inherit xorg-2
  9. EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/util-cursor"
  10. EGIT_HAS_SUBMODULES=yes
  11. DESCRIPTION="X C-language Bindings sample implementations"
  12. HOMEPAGE="https://xcb.freedesktop.org/"
  13. KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris"
  14. IUSE="test"
  15. RDEPEND=">=x11-libs/libxcb-1.9.1[${MULTILIB_USEDEP}]
  16. >=x11-libs/xcb-util-image-0.3.9-r1[${MULTILIB_USEDEP}]
  17. >=x11-libs/xcb-util-renderutil-0.3.9[${MULTILIB_USEDEP}]
  18. >=x11-proto/xcb-proto-1.8-r3:=[${MULTILIB_USEDEP}]
  19. >=x11-proto/xproto-7.0.24:=[${MULTILIB_USEDEP}]"
  20. DEPEND="${RDEPEND}
  21. >=dev-util/gperf-3.0.1
  22. test? ( >=dev-libs/check-0.9.11[${MULTILIB_USEDEP}] )"
  23. src_configure() {
  24. XORG_CONFIGURE_OPTIONS=(
  25. $(use_with doc doxygen)
  26. )
  27. xorg-2_src_configure
  28. }