12345678910111213141516171819202122232425262728293031323334353637383940 |
- # Copyright 1999-2017 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=5
- inherit eutils toolchain-funcs
- DESCRIPTION="Simple screen locker"
- HOMEPAGE="http://i3wm.org/i3lock/"
- SRC_URI="http://i3wm.org/${PN}/${P}.tar.bz2"
- LICENSE="BSD"
- SLOT="0"
- KEYWORDS="amd64 x86"
- IUSE=""
- RDEPEND="virtual/pam
- dev-libs/libev
- >=x11-libs/libxkbcommon-0.5.0[X]
- x11-libs/libxcb[xkb]
- x11-libs/xcb-util
- x11-libs/cairo[xcb]"
- DEPEND="${RDEPEND}
- virtual/pkgconfig"
- DOCS=( CHANGELOG README.md )
- pkg_setup() {
- tc-export CC
- }
- src_prepare() {
- sed -i -e 's:login:system-auth:' ${PN}.pam || die
- epatch_user
- }
- src_install() {
- default
- doman ${PN}.1
- }
|