imwheel-1.0.0_pre12.ebuild 1.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Copyright 1999-2008 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils
  4. DESCRIPTION="mouse tool for advanced features such as wheels and 3+ buttons"
  5. HOMEPAGE="http://imwheel.sourceforge.net/"
  6. SRC_URI="mirror://sourceforge/imwheel/${P/_/}.tar.gz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="alpha amd64 ppc x86"
  10. IUSE=""
  11. RDEPEND="x11-libs/libXtst
  12. x11-libs/libX11
  13. x11-libs/libXmu
  14. x11-libs/libXt
  15. x11-libs/libXext"
  16. DEPEND="${RDEPEND}
  17. x11-proto/inputproto
  18. x11-proto/xextproto
  19. x11-proto/xproto
  20. >=sys-apps/sed-4"
  21. S=${WORKDIR}/${P/_/}
  22. src_unpack() {
  23. unpack ${A}
  24. cd "${S}"
  25. #epatch "${FILESDIR}"/${P}-gentoo.diff
  26. sed -i -e "s:/etc:${D}/etc:g" Makefile.am || die
  27. sed -i -e "s:/etc:${D}/etc:g" Makefile.in || die
  28. }
  29. src_compile() {
  30. local myconf
  31. # don't build gpm stuff
  32. myconf="--disable-gpm --disable-gpm-doc"
  33. econf ${myconf} || die "configure failed"
  34. emake || die "parallel make failed"
  35. }
  36. src_install() {
  37. einstall || die "make install failed"
  38. dodoc AUTHORS BUGS ChangeLog EMACS M-BA47 NEWS README TODO
  39. }