tint2-0.12.12.ebuild 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit cmake-utils gnome2-utils vcs-snapshot
  5. DESCRIPTION="tint2 is a lightweight panel/taskbar for Linux."
  6. HOMEPAGE="https://gitlab.com/o9000/tint2"
  7. SRC_URI="https://gitlab.com/o9000/${PN}/repository/archive.tar.gz?ref=v${PV} -> ${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE="battery svg startup-notification tint2conf"
  12. DEPEND="
  13. dev-libs/glib:2
  14. svg? ( gnome-base/librsvg:2 )
  15. >=media-libs/imlib2-1.4.2[X,png]
  16. x11-libs/cairo[X]
  17. x11-libs/pango
  18. tint2conf? ( x11-libs/gtk+:2 )
  19. x11-libs/libX11
  20. x11-libs/libXcomposite
  21. x11-libs/libXdamage
  22. x11-libs/libXinerama
  23. >=x11-libs/libXrandr-1.3
  24. x11-libs/libXrender
  25. startup-notification? ( x11-libs/startup-notification )
  26. "
  27. RDEPEND="${DEPEND}"
  28. PATCHES=(
  29. "${FILESDIR}/${PV}-fix-compilation-without-svg.patch"
  30. "${FILESDIR}/${PV}-no-hardcode-update-icon-cache.patch"
  31. "${FILESDIR}/${PV}-relax-pango-includes.patch"
  32. )
  33. src_configure() {
  34. local mycmakeargs=(
  35. -DENABLE_BATTERY="$(usex battery)"
  36. -DENABLE_TINT2CONF="$(usex tint2conf)"
  37. -DENABLE_SN="$(usex startup-notification)"
  38. -DENABLE_RSVG="$(usex svg)"
  39. )
  40. cmake-utils_src_configure
  41. }
  42. src_install() {
  43. cmake-utils_src_install
  44. }
  45. pkg_preinst() {
  46. gnome2_icon_savelist
  47. }
  48. pkg_postinst() {
  49. gnome2_icon_cache_update
  50. }
  51. pkg_postrm() {
  52. gnome2_icon_cache_update
  53. }