trayer-srg-1.1.6-r1.ebuild 651 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit toolchain-funcs vcs-snapshot
  5. DESCRIPTION="trayer fork with multi monitor support and cleaned up codebase"
  6. HOMEPAGE="https://github.com/sargon/trayer-srg"
  7. SRC_URI="https://github.com/sargon/${PN}/tarball/${P/-srg/} -> ${P}.tar.gz"
  8. LICENSE="MIT GPL-2+"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE=""
  12. RDEPEND="x11-libs/gdk-pixbuf:2[X]
  13. x11-libs/gtk+:2
  14. x11-libs/libX11
  15. x11-libs/libXmu"
  16. DEPEND="${RDEPEND}
  17. virtual/pkgconfig"
  18. src_compile() {
  19. emake DEVEL=1 TARGET=${PN} CC="$(tc-getCC)"
  20. }
  21. src_install() {
  22. dobin ${PN}
  23. einstalldocs
  24. }