pidgin-indicator-1.0.ebuild 612 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools
  5. DESCRIPTION="Indicator plugin for Pidgin"
  6. HOMEPAGE="https://github.com/philipl/pidgin-indicator"
  7. SRC_URI="https://github.com/philipl/pidgin-indicator/archive/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64"
  11. IUSE=""
  12. RDEPEND="dev-libs/glib:2
  13. dev-libs/libappindicator:2
  14. net-im/pidgin[gtk]
  15. x11-libs/gtk+:2"
  16. DEPEND="${RDEPEND}
  17. virtual/pkgconfig"
  18. src_prepare() {
  19. eautoreconf
  20. }
  21. src_install() {
  22. default
  23. find "${D}" -name "*.la" -exec rm {} + || die
  24. }