pidgin-latex-1.5.0.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit multilib toolchain-funcs
  5. MY_P=${PN}_${PV}
  6. DESCRIPTION="Pidgin plugin that renders latex formulae"
  7. HOMEPAGE="https://sourceforge.net/projects/pidgin-latex/"
  8. SRC_URI="mirror://sourceforge/pidgin-latex/${MY_P}.tar.bz2"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="amd64 ~ppc x86"
  12. IUSE=""
  13. COMMON_DEPEND="
  14. net-im/pidgin[gtk]
  15. x11-libs/gtk+:2"
  16. DEPEND="${COMMON_DEPEND}
  17. sys-devel/libtool
  18. virtual/pkgconfig"
  19. RDEPEND="${COMMON_DEPEND}
  20. virtual/latex-base
  21. app-text/dvipng"
  22. S=${WORKDIR}/${PN}
  23. src_prepare() {
  24. sed -e "s:\(CC.*=\).*:\1 $(tc-getCC):" \
  25. -e "/LIB_INSTALL_DIR/{s:/lib/pidgin:/$(get_libdir)/pidgin:;}" \
  26. -i Makefile || die
  27. }
  28. src_install() {
  29. emake PREFIX="${D}/usr" install
  30. dodoc README CHANGELOG TODO
  31. }
  32. pkg_postinst() {
  33. elog 'Note, to see formulas either disable "Conversation Colors" plugin or'
  34. elog 'switch off "ignore incoming format" option in plugin configuration.'
  35. elog 'For details, take a look (and vote) at http://developer.pidgin.im/ticket/2772'
  36. }