wmSun-1.03-r1.ebuild 892 B

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils multilib toolchain-funcs
  4. DESCRIPTION="dockapp which displays the rise/set time of the sun"
  5. HOMEPAGE="http://dockapps.windowmaker.org/file.php/id/16"
  6. SRC_URI="http://dockapps.windowmaker.org/download.php/id/23/${P}.tar.gz"
  7. SLOT="0"
  8. LICENSE="GPL-2"
  9. KEYWORDS="amd64 ~mips ppc sparc x86"
  10. IUSE=""
  11. RDEPEND="x11-libs/libX11
  12. x11-libs/libXext
  13. x11-libs/libXpm"
  14. DEPEND="${RDEPEND}
  15. x11-proto/xproto
  16. x11-proto/xextproto"
  17. S="${WORKDIR}/${P}/${PN}"
  18. src_unpack() {
  19. unpack ${A}
  20. cd "${S}"
  21. epatch "${FILESDIR}"/${P}-makefile.patch
  22. }
  23. src_compile() {
  24. emake clean || die "make clean failed"
  25. emake CC="$(tc-getCC)" LIBDIR="/usr/$(get_libdir)" || die "parallel make failed"
  26. }
  27. src_install() {
  28. emake DESTDIR="${D}" install || die "install failed"
  29. dodoc README ../{BUGS,TODO}
  30. }