wmbutton-0.6.1.ebuild 966 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils toolchain-funcs
  4. DESCRIPTION="a dockapp application that displays nine configurable buttons"
  5. HOMEPAGE="http://www.freshports.org/x11/wmbutton"
  6. SRC_URI="ftp://ftp.freebsd.org/pub/FreeBSD/ports/distfiles/${P}.tar.gz
  7. branding? ( mirror://gentoo/${PN}-buttons.xpm )"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc sparc x86"
  11. IUSE="branding"
  12. RDEPEND="x11-libs/libX11
  13. x11-libs/libXpm
  14. x11-libs/libXext"
  15. DEPEND="${RDEPEND}
  16. x11-proto/xextproto
  17. x11-proto/xproto
  18. dev-util/ctags"
  19. src_unpack() {
  20. unpack ${P}.tar.gz
  21. cd "${S}"
  22. epatch "${FILESDIR}"/${P}-Makefile.patch
  23. use branding && cp "${DISTDIR}"/${PN}-buttons.xpm buttons.xpm
  24. }
  25. src_compile() {
  26. emake CC="$(tc-getCC)" || die "emake failed."
  27. }
  28. src_install() {
  29. dobin ${PN}
  30. dodoc README
  31. use branding && dodoc "${FILESDIR}"/sample.wmbutton
  32. use branding || newdoc .wmbutton sample.wmbutton
  33. }