wmudmount-2.2-r2.ebuild 863 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils gnome2-utils xdg
  5. DESCRIPTION="A filesystem mounter that uses udisks to handle notification and mounting"
  6. HOMEPAGE="https://sourceforge.net/projects/wmudmount/"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="gnome-keyring libnotify"
  12. RDEPEND="sys-fs/udisks:2
  13. >=x11-libs/gtk+-3.8.0:3
  14. gnome-keyring? ( gnome-base/libgnome-keyring )
  15. libnotify? ( >=x11-libs/libnotify-0.7 )"
  16. DEPEND="${RDEPEND}
  17. virtual/pkgconfig
  18. virtual/imagemagick-tools[png]"
  19. DOCS="ChangeLog"
  20. src_configure() {
  21. econf \
  22. $(use_with libnotify) \
  23. $(use_with gnome-keyring)
  24. }
  25. pkg_preinst() { gnome2_icon_savelist; }
  26. pkg_postinst() { gnome2_icon_cache_update; }
  27. pkg_postrm() { gnome2_icon_cache_update; }