bspwm-0.9.2.ebuild 956 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit toolchain-funcs
  5. DESCRIPTION="Tiling window manager based on binary space partitioning"
  6. HOMEPAGE="https://github.com/baskerville/bspwm/"
  7. SRC_URI="https://github.com/baskerville/bspwm/archive/${PV}.tar.gz -> ${P}.tar.gz"
  8. LICENSE="BSD-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="examples"
  12. DEPEND="
  13. x11-libs/libxcb
  14. x11-libs/xcb-util
  15. x11-libs/xcb-util-wm
  16. "
  17. RDEPEND="${DEPEND}
  18. x11-misc/sxhkd
  19. "
  20. src_compile() {
  21. emake PREFIX=/usr CC="$(tc-getCC)"
  22. }
  23. src_install() {
  24. emake DESTDIR="${D}" PREFIX=/usr install
  25. dodoc doc/{CONTRIBUTING,MISC,TODO}.md
  26. exeinto /etc/X11/Sessions
  27. newexe "${FILESDIR}"/${PN}-session ${PN}
  28. insinto /usr/share/xsessions
  29. doins contrib/freedesktop/bspwm.desktop
  30. insinto /etc/xdg/sxhkd
  31. doins examples/sxhkdrc
  32. if use examples ; then
  33. dodoc -r examples
  34. docompress -x /usr/share/doc/${PF}/examples
  35. fi
  36. }