jwm-2.3.2.ebuild 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. DESCRIPTION="Very fast and lightweight still powerful window manager for X"
  6. HOMEPAGE="http://joewing.net/projects/jwm/"
  7. SRC_URI="http://joewing.net/programs/jwm/releases/${P}.tar.xz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 hppa ppc x86 ~x86-fbsd"
  11. IUSE="bidi debug jpeg png truetype xinerama xpm"
  12. RDEPEND="xpm? ( x11-libs/libXpm )
  13. xinerama? ( x11-libs/libXinerama )
  14. x11-libs/libXext
  15. x11-libs/libXrender
  16. x11-libs/libXau
  17. x11-libs/libXdmcp
  18. truetype? ( x11-libs/libXft )
  19. png? ( media-libs/libpng:0= )
  20. jpeg? ( virtual/jpeg:0= )
  21. bidi? ( dev-libs/fribidi )
  22. dev-libs/expat"
  23. DEPEND="${RDEPEND}
  24. x11-proto/xproto
  25. x11-proto/xextproto
  26. xinerama? ( x11-proto/xineramaproto )"
  27. src_configure() {
  28. econf \
  29. $(use_enable debug) \
  30. $(use_enable jpeg) \
  31. $(use_enable png) \
  32. $(use_enable truetype xft) \
  33. $(use_enable xinerama) \
  34. $(use_enable xpm) \
  35. $(use_enable bidi fribidi) \
  36. --enable-shape \
  37. --enable-xrender
  38. }
  39. src_install() {
  40. dodir /etc
  41. dodir /usr/bin
  42. dodir /usr/share/man
  43. default
  44. make_wrapper "${PN}" "/usr/bin/${PN}" "" "" "/etc/X11/Sessions"
  45. dodoc README.md example.jwmrc ChangeLog
  46. }
  47. pkg_postinst() {
  48. einfo "JWM can be configured system-wide with ${EROOT}/etc/system.jwmrc"
  49. einfo "or per-user by creating a configuration file in ~/.jwmrc"
  50. einfo
  51. einfo "An example file can be found in ${EROOT}/usr/share/doc/${PF}/"
  52. }