windowmaker-0.95.8.ebuild 2.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils
  5. DESCRIPTION="The fast and light GNUstep window manager"
  6. HOMEPAGE="http://www.windowmaker.org/"
  7. SRC_URI=" http://windowmaker.org/pub/source/release/${P/windowm/WindowM}.tar.gz
  8. http://www.windowmaker.org/pub/source/release/WindowMaker-extra-0.1.tar.gz"
  9. SLOT="0"
  10. LICENSE="GPL-2"
  11. IUSE="gif imagemagick jpeg modelock nls png tiff webp xinerama +xpm xrandr"
  12. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
  13. DEPEND="media-libs/fontconfig
  14. >=x11-libs/libXft-2.1.0
  15. x11-libs/libXmu
  16. x11-libs/libXpm
  17. x11-libs/libXt
  18. x11-libs/libXv
  19. gif? ( >=media-libs/giflib-4.1.0-r3 )
  20. imagemagick? ( media-gfx/imagemagick )
  21. jpeg? ( virtual/jpeg:0= )
  22. png? ( media-libs/libpng:0= )
  23. tiff? ( media-libs/tiff:0 )
  24. webp? ( media-libs/libwebp )
  25. xinerama? ( x11-libs/libXinerama )
  26. xrandr? ( x11-libs/libXrandr )"
  27. RDEPEND="${DEPEND}
  28. nls? ( >=sys-devel/gettext-0.10.39 )"
  29. S=${WORKDIR}/${P/windowm/WindowM}
  30. src_prepare() {
  31. # Fix some paths
  32. for file in WindowMaker/*menu* util/wmgenmenu.c; do
  33. if [[ -r $file ]] ; then
  34. sed -i -e "s:/usr/local/GNUstep/Applications/WPrefs.app:${EPREFIX}/usr/bin/:g;" "$file" || die
  35. sed -i -e "s:/usr/local/share/WindowMaker:${EPREFIX}/usr/share/WindowMaker:g;" "$file" || die
  36. sed -i -e "s:/opt/share/WindowMaker:${EPREFIX}/usr/share/WindowMaker:g;" "$file" || die
  37. fi;
  38. done;
  39. default
  40. }
  41. src_configure() {
  42. local myconf
  43. # image format types
  44. myconf="$(use_enable imagemagick magick) $(use_enable jpeg) $(use_enable gif) $(use_enable png) $(use_enable tiff) $(use_enable webp) $(use_enable xpm)"
  45. # non required X capabilities
  46. myconf="${myconf} $(use_enable modelock) $(use_enable xrandr randr) $(use_enable xinerama)"
  47. if use nls; then
  48. [[ -z $LINGUAS ]] && export LINGUAS="$(ls po/*.po | sed 's:po/\(.*\)\.po$:\1:' | xargs)"
  49. else
  50. myconf="${myconf} --disable-locale"
  51. fi
  52. # default settings with $myconf appended
  53. econf \
  54. --sysconfdir="${EPREFIX}"/etc/X11 \
  55. --with-x \
  56. --enable-usermenu \
  57. --with-pixmapdir="${EPREFIX}"/usr/share/pixmaps \
  58. --localedir="${EPREFIX}"/usr/share/locale \
  59. ${myconf}
  60. cd ../WindowMaker-extra-0.1
  61. econf
  62. }
  63. src_compile() {
  64. emake
  65. # WindowMaker Extra Package (themes and icons)
  66. cd ../WindowMaker-extra-0.1
  67. emake
  68. }
  69. src_install() {
  70. emake DESTDIR="${D}" install
  71. dodoc AUTHORS BUGFORM BUGS ChangeLog INSTALL* FAQ* \
  72. README* NEWS TODO
  73. # WindowMaker Extra
  74. cd ../WindowMaker-extra-0.1
  75. emake DESTDIR="${D}" install
  76. newdoc README README.extra
  77. # create wmaker session shell script
  78. echo "#!/usr/bin/env bash" > wmaker
  79. echo "${EPREFIX}/usr/bin/wmaker" >> wmaker
  80. exeinto /etc/X11/Sessions/
  81. doexe wmaker
  82. insinto /usr/share/xsessions
  83. doins "${FILESDIR}"/wmaker.desktop
  84. make_desktop_entry /usr/bin/wmaker
  85. }