xfce4-quicklauncher-plugin-1.9.4-r1.ebuild 1.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. #EAUTORECONF=yes
  5. inherit autotools xfconf
  6. DESCRIPTION="A quicklauncher plug-in for the Xfce panel"
  7. HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-quicklauncher-plugin"
  8. SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
  12. IUSE="debug"
  13. RDEPEND=">=xfce-base/xfce4-panel-4.8
  14. >=xfce-base/libxfcegui4-4.8"
  15. DEPEND="${RDEPEND}
  16. dev-util/intltool
  17. >=dev-util/xfce4-dev-tools-4.8
  18. virtual/pkgconfig"
  19. pkg_setup() {
  20. PATCHES=( "${FILESDIR}"/${P}-X-XFCE-Module-Path.patch )
  21. XFCONF=(
  22. $(use_enable debug)
  23. )
  24. DOCS=( AUTHORS ChangeLog TODO )
  25. }
  26. src_prepare() {
  27. sed -i \
  28. -e '/^AC_INIT/s:quicklauncher_version():quicklauncher_version:' \
  29. -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' \
  30. configure.ac || die #472522
  31. # Prevent glib-gettextize from running wrt #423115
  32. export AT_M4DIR=${EPREFIX}/usr/share/xfce4/dev-tools/m4macros
  33. intltoolize --automake --copy --force
  34. _elibtoolize --copy --force --install
  35. eaclocal
  36. eautoconf
  37. eautoheader
  38. eautomake
  39. xfconf_src_prepare
  40. }