obnam-1.19.1.ebuild 976 B

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. PYTHON_REQ_USE="threads"
  6. inherit distutils-r1
  7. DESCRIPTION="A backup program that supports encryption and deduplication"
  8. HOMEPAGE="http://obnam.org/"
  9. SRC_URI="http://git.liw.fi/cgi-bin/cgit/cgit.cgi/obnam/snapshot/${P}.tar.gz"
  10. LICENSE="GPL-3"
  11. SLOT="0"
  12. KEYWORDS="~amd64 ~x86"
  13. IUSE=""
  14. DEPEND="${PYTHON_DEPS}
  15. dev-python/cliapp[${PYTHON_USEDEP}]
  16. dev-python/fuse-python[${PYTHON_USEDEP}]
  17. dev-python/larch[${PYTHON_USEDEP}]
  18. dev-python/paramiko[${PYTHON_USEDEP}]
  19. dev-python/pyyaml[${PYTHON_USEDEP}]
  20. dev-python/tracing[${PYTHON_USEDEP}]
  21. dev-python/ttystatus[${PYTHON_USEDEP}]
  22. "
  23. RDEPEND="${DEPEND}"
  24. src_compile() {
  25. addwrite /proc/self/comm
  26. distutils-r1_src_compile
  27. }
  28. src_install() {
  29. distutils-r1_src_install
  30. find "${D}" -name "obnam-viewprof*" -delete
  31. insinto /etc
  32. doins "${FILESDIR}"/obnam.conf
  33. keepdir /var/log/obnam
  34. }