contest-0.61-r1.ebuild 752 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit flag-o-matic toolchain-funcs
  5. DESCRIPTION="Test system responsiveness to compare different kernels"
  6. HOMEPAGE="http://users.tpg.com.au/ckolivas/contest/"
  7. SRC_URI="http://www.tux.org/pub/kernel/people/ck/apps/${PN}/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86"
  11. RDEPEND=">=app-benchmarks/dbench-2.0"
  12. PATCHES=(
  13. "${FILESDIR}/${PN}-fortify_sources.patch"
  14. "${FILESDIR}/${P}-fix-buildsystem.patch"
  15. )
  16. src_prepare () {
  17. # fix #570250 by restoring pre-GCC5 inline semantics
  18. append-cflags -std=gnu89
  19. default
  20. tc-export CC
  21. }
  22. src_compile() {
  23. emake
  24. }
  25. src_install() {
  26. dobin contest
  27. doman contest.1
  28. dodoc README
  29. }