acetoneiso-2.3.ebuild 960 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. MY_P=${PN}_${PV}
  5. inherit flag-o-matic qt4-r2
  6. DESCRIPTION="a feature-rich and complete software application to manage CD/DVD images"
  7. HOMEPAGE="https://sourceforge.net/projects/${PN}/"
  8. SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~x86"
  12. IUSE="kde"
  13. DEPEND="dev-qt/qtcore:4
  14. dev-qt/qtdbus:4
  15. dev-qt/qtgui:4
  16. dev-qt/qtwebkit:4
  17. kde? ( media-libs/phonon[qt4] )
  18. !kde? ( || ( dev-qt/qtphonon:4 media-libs/phonon[qt4] ) )"
  19. RDEPEND="${DEPEND}
  20. sys-fs/fuseiso"
  21. S=${WORKDIR}/${MY_P}/${PN}
  22. DOCS=(../AUTHORS ../CHANGELOG ../FEATURES ../README)
  23. src_prepare() {
  24. sed -i -e 's:unrar-nonfree:unrar:g' sources/compress.h locale/*.ts || die
  25. sed -i -e 's:include <Phonon/:include <:' sources/* || die "phonon sed failed"
  26. }
  27. src_configure() {
  28. append-cxxflags -I/usr/include/KDE/Phonon
  29. qt4-r2_src_configure
  30. }