cddetect-2.1.ebuild 561 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit toolchain-funcs
  5. DESCRIPTION="A tool for detecting the type of a CD/DVD without mounting it"
  6. HOMEPAGE="http://www.bellut.net/projects.html"
  7. SRC_URI="http://www.bellut.net/files/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE=""
  12. S=${WORKDIR}
  13. src_prepare() {
  14. sed -i -e '1i#include <limits.h>' ${PN}.c || die #337628
  15. }
  16. src_compile() {
  17. emake CC="$(tc-getCC)" CFLAGS="-Wall ${CFLAGS}"
  18. }
  19. src_install() {
  20. dobin ${PN}
  21. }