acme-9999.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. PYTHON_COMPAT=(python{2_7,3_4,3_5})
  5. if [[ ${PV} == 9999* ]]; then
  6. EGIT_REPO_URI="https://github.com/certbot/certbot.git"
  7. inherit git-r3
  8. S=${WORKDIR}/${P}/${PN}
  9. else
  10. SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.tar.gz"
  11. KEYWORDS="~amd64 ~arm ~x86"
  12. S=${WORKDIR}/certbot-${PV}/acme
  13. fi
  14. inherit distutils-r1
  15. DESCRIPTION="An implementation of the ACME protocol"
  16. HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
  17. LICENSE="Apache-2.0"
  18. SLOT="0"
  19. IUSE="test"
  20. RDEPEND=">=dev-python/cryptography-0.8[${PYTHON_USEDEP}]
  21. dev-python/mock[${PYTHON_USEDEP}]
  22. >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
  23. dev-python/pyrfc3339[${PYTHON_USEDEP}]
  24. dev-python/pytz[${PYTHON_USEDEP}]
  25. >=dev-python/requests-2.4.1[${PYTHON_USEDEP}]
  26. dev-python/six[${PYTHON_USEDEP}]"
  27. DEPEND="test? ( ${RDEPEND} dev-python/nose[${PYTHON_USEDEP}] )
  28. >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]"
  29. python_test() {
  30. nosetests -w ${PN} || die
  31. }