dieharder-3.31.1-r1.ebuild 912 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="An advanced suite for testing the randomness of RNG's"
  5. HOMEPAGE="http://www.phy.duke.edu/~rgb/General/dieharder.php"
  6. SRC_URI="http://www.phy.duke.edu/~rgb/General/${PN}/${P}.tgz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
  10. IUSE="doc"
  11. RDEPEND="sci-libs/gsl"
  12. DEPEND="${RDEPEND}
  13. doc? ( dev-tex/latex2html )"
  14. DOCS=(
  15. NOTES
  16. )
  17. HTML_DOCS=()
  18. PATCHES=(
  19. "${FILESDIR}/${P}-build.patch"
  20. )
  21. pkg_setup() {
  22. use doc && DOCS+=(
  23. ChangeLog
  24. manual/dieharder.pdf manual/dieharder.ps
  25. )
  26. use doc && HTML_DOCS+=(
  27. dieharder.html
  28. )
  29. }
  30. src_compile() {
  31. emake -j1
  32. use doc && emake -C manual
  33. }
  34. src_install() {
  35. default
  36. docinto "dieharder"
  37. dodoc dieharder/README dieharder/NOTES
  38. docinto "libdieharder"
  39. dodoc libdieharder/README libdieharder/NOTES
  40. }