myspell-pl-20130306.ebuild 1000 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. MYSPELL_DICT=(
  5. "pl_PL.aff"
  6. "pl_PL.dic"
  7. )
  8. MYSPELL_HYPH=(
  9. "hyph_pl_PL.dic"
  10. )
  11. MYSPELL_THES=(
  12. "th_pl_PL_v2.dat"
  13. "th_pl_PL_v2.idx"
  14. )
  15. inherit myspell-r2
  16. DESCRIPTION="Polish dictionaries for myspell/hunspell"
  17. # dict is bumped every day but nothing changes, RECHECK BEFORE DOING VERSION BUMP!
  18. # hyphen has no website
  19. # thesarus released last in 2k8
  20. HOMEPAGE="
  21. http://www.sjp.pl/slownik/en/
  22. https://sourceforge.net/projects/synonimy/
  23. "
  24. SRC_URI="
  25. http://sjp.pl/slownik/ort/sjp-myspell-pl-${PV}.zip
  26. http://www.openoffice.org/pl/pliki/hyph_pl_PL.zip -> ${P}-hyph.zip
  27. mirror://sourceforge/synonimy/OOo2-Thesaurus-1.5.zip -> ${P}-thes.zip
  28. "
  29. LICENSE="CC-SA-1.0 LGPL-3 GPL-3 MPL-1.1"
  30. SLOT="0"
  31. KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd"
  32. IUSE=""
  33. src_unpack() {
  34. myspell-r2_src_unpack
  35. # ZIPCEPTION!
  36. unzip hyph_pl_PL.zip
  37. unzip pl_PL.zip
  38. }