emms-3.0-r1.ebuild 1015 B

1234567891011121314151617181920212223242526272829303132333435363738394041
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit elisp toolchain-funcs
  5. DESCRIPTION="The Emacs Multimedia System"
  6. HOMEPAGE="https://www.gnu.org/software/emms/
  7. http://www.emacswiki.org/emacs/EMMS"
  8. SRC_URI="https://www.gnu.org/software/emms/download/${P}.tar.gz"
  9. LICENSE="GPL-3+ FDL-1.1+"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~ppc ~sparc ~x86"
  12. DEPEND="media-libs/taglib"
  13. RDEPEND="${DEPEND}"
  14. # EMMS can use almost anything for playing media files therefore the dependency
  15. # possibilities are so broad that we refrain from setting anything explicitly
  16. # in DEPEND/RDEPEND.
  17. ELISP_PATCHES="${P}-Makefile.patch
  18. ${P}-texinfo-5.patch"
  19. SITEFILE="50${PN}-gentoo.el"
  20. src_compile() {
  21. emake CC="$(tc-getCC)" \
  22. EMACS=emacs \
  23. all emms-print-metadata
  24. }
  25. src_install() {
  26. elisp-install ${PN} *.{el,elc}
  27. elisp-site-file-install "${FILESDIR}/${SITEFILE}"
  28. doinfo *.info*
  29. dobin *-wrapper emms-print-metadata
  30. dodoc AUTHORS ChangeLog FAQ NEWS README RELEASE
  31. }