nxml-svg-schemas-1.1.20081123.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit elisp
  5. DESCRIPTION="Extension for nxml-mode with SVG 1.1 schemas"
  6. HOMEPAGE="http://www.w3.org/TR/SVG11/"
  7. # original SRC_URI is http://www.w3.org/Graphics/SVG/1.1/rng/rng.zip
  8. # but since it's unversioned, I versioned it and got it locally.
  9. SRC_URI="http://www.flameeyes.eu/gentoo-distfiles/w3c-svg-rng-${PV}.zip"
  10. LICENSE="HPND"
  11. # In a future we might have 1.2 schemas too, but for now we can only
  12. # install this one anyway because the schemas.xml syntax is not
  13. # sophisticated enough.
  14. SLOT="1.1"
  15. KEYWORDS="amd64 ~x86"
  16. # Yes this requires Java, but I'd rather not repackage this, if you
  17. # know something better in C, I'll be glad to use that.
  18. DEPEND="app-text/trang"
  19. RDEPEND=""
  20. S="${WORKDIR}"
  21. SITEFILE="60${PN}-gentoo.el"
  22. src_prepare() {
  23. # we don't need the doctype for our work
  24. sed -i -e '/DOCTYPE grammar/d' *.rng || die "sed failed"
  25. }
  26. src_compile() {
  27. emake -f "${FILESDIR}/Makefile-trang"
  28. }
  29. src_install() {
  30. insinto "${SITEETC}/${PN}"
  31. doins "${FILESDIR}/schemas.xml" *.rnc
  32. elisp-site-file-install "${FILESDIR}/${SITEFILE}"
  33. }